alternatetext
Thomasville/Quitman GA- Emergency Fiber Maintenance
Incident Report for CNS Next
Resolved
Fiber repair work has been completed.
Posted Nov 15, 2024 - 13:52 EST
Identified
CNS fiber teams are actively addressing damaged fiber in Thomasville, GA. This fiber run also connects to Quitman, GA, and has sustained additional damage, likely caused by squirrels. We are committed to completing the repairs as quickly as possible to minimize any disruptions.

Thank you for your patience and understanding as we work to restore service.
Posted Nov 15, 2024 - 09:39 EST
This incident affected: Core Network (Quitman).