alternatetext

Thomasville Camilla Fiber issue

Incident Report for CNS Next

Resolved

Our third-party provider has confirmed that all work has been completed, and all services restored. Thank you for your patience regarding this issue.
Posted Nov 26, 2025 - 19:42 EST

Investigating

We are investigating an issue on the core link between Thomasville and Camilla and are working with our third-party carrier to restore services.
Posted Nov 25, 2025 - 21:14 EST
This incident affected: CNSNext Services (Camilla - Cable Customers, NextStream TV) and Core Network (Camilla, Thomasville - Headend).