alternatetext

Thomasville Central Office - Outage

Incident Report for CNS Next

Resolved

Power has been restored at the Central Office. All circuits are operational.
Posted May 07, 2026 - 14:57 EDT

Monitoring

There was a brief power outage at our Central Office. The building is on backup generators while power is being restored. Core circuits are all operational. There are a handful of customer circuits that are still down due to power.

We will continue to monitor until power is restored.
Posted May 07, 2026 - 12:42 EDT

Investigating

We are investigating storm related outages in Thomasville GA.
Posted May 07, 2026 - 12:18 EDT
This incident affected: Core Network (Thomasville - Central Office).